[Docscaliu-info]Dubte APT-GET

Josep Ma. Ferrer josep.m.ferrer a wanadoo.es
dim set 9 16:33:30 CEST 2003


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

En/na Orestes Mas ha escrit:
> Mmmm... gràcies per l'apunt, però em deu fallar alguna cosa més. L'ordre
> que esmentes em dóna com a resultat:
> ---------
> raimon:/home/orestes# apt-get dist-upgrade -ds
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Calculating Upgrade... Done
> The following packages will be REMOVED:
>  gnucash
> The following NEW packages will be installed:
>  classpath debconf-i18n libgcj-common liblocale-gettext-perl
> libtext-charwidth-perl libtext-iconv-perl
>  libtext-wrapi18n-perl python2.3
> The following packages have been kept back
>  alsaplayer-alsa alsaplayer-common alsaplayer-gtk alsaplayer-oss
> alsaplayer-text apt-file audacity gaim gdm
>  gnomemeeting libquicktime1 rep-gtk-gnome sox timidity vorbis-tools
> vorbisgain
> 11 packages upgraded, 8 newly installed, 1 to remove and 16  not upgraded.
>
> Per tant, res d'actualitzar el kde.

Efectivament, no s'actualitza el kde. Però hi ha més programari a
actualitzar.

>
> He mirat de fer un dpkg -s kde i em diu que no està instal.lat!
> -------
> raimon:/home/orestes# dpkg -s kde
> Package: kde
> Status: purge ok not-installed
> Priority: optional
> Section: x11

"kde" és un metapaquet. Jo el tinc igual:

Package: kde
Status: purge ok not-installed

>
> I un "dpkg -s kdebase diu que tinc instal.lada una KDE 2.2! (Però jo
> veig al menú que surt KDE 3.1 i l'aspecte és de kde3...)
> ---------
> raimon:/home/orestes# dpkg -s kdebase
> Package: kdebase
> Status: deinstall ok config-files          <-- Què vol dir "deinstall"?

"deinstall" vol dir que està desinstal·lat, i que encara tens els
fitxers de configuració.

> Priority: optional
> Section: x11
> Installed-Size: 16280
> Maintainer: Christopher L Cheney <ccheney a debian.org>
> Version: 4:2.2.2-14.2
> Config-Version: 4:2.2.2-14.2
> [...]
>
> En resum, que com més m'ho miro més em temo que alguna cosa ha quedat
> instal.lada als llimbs.
>
> Algun consell per recuperar una situació controlada?
>


Em sembla que hi ha algun problema addicional. Com vas instal·lar el kde
per darrera vegada? Sembla com si no hagi quedat registrat a la BBDD de
paquets. Que et surt quan fas això:

$ dpkg -l |grep kde
ii  kde-i18n-ca    3.1.3-0woody1  Catalan (ca) i18n files for KDE
ii  kdeaddons      3.1.3-0woody1  add-on plugins and applets provided
with KDE
ii  kdeaddons-kfil 3.1.3-0woody1  KDE file dialog plugins for text files
and f
ii  kdebase        3.1.3-0woody1  KDE Base metapackage
ii  kdebase-bin    3.1.3-0woody1  KDE Base (binaries)
ii  kdebase-data   3.1.3-0woody1  KDE Base (shared data)
etc.

Jo intentaria:

1r) Eliminar o comentar momentaneament la línia del sources.list que fa
referència a kde. I fer:

apt-get update
apt-get dist-upgrade

I solucionar els problemes amb la resta de programes a actualitzar.
Potser tinguis que fer varies vegades "apt-get dist-upgrade".

2n) Un cop acabat amb éxit el punt anterior, i per actualitzar el kde a
la darrera versió (3.1.3) posa la següent línia al sources.list:

deb ftp://download.uk.kde.org/pub/kde/stable/latest/Debian woody main

Potser tinguis que triar un a un els paquets de kde que t'interesin.

Vés amb compte. Sort!

- --
*-------------------------------------------------*
|   Linux User: 154.147 (http://counter.li.org)   |
|  GPG KeyID: 0x4E91BFA1 (http://pgp.rediris.es)  |
*-------------------------------------------------*
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE/Xk0W/ElsA06Rv6ERAuizAJ9phUanzjBLkjyuwX2+F+C6cZsUngCfQmUB
XsSpWBT1CqqSkU28tzkeoX0=
=qC4Z
-----END PGP SIGNATURE-----





Més informació sobre la llista de correu caliu-info