[Ubuntucat-info] VNC no em rula

Moises Belda moises a cinenautas.com
dic oct 10 17:51:43 CEST 2007


Torne a rependre aquest fil sobre el problema del acces per VNC amb el
Escriptori remot (vino) de ubuntu.

No he trobat encara sol.lució pero si alguns posts que tenen el mateix
problema

http://ubuntuforums.org/showthread.php?t=273402&highlight=vino+authentication+failure

Alli comenta una posible sol.lució de que podria estar el password
guardant-se en codificacio base64. Jo no havia sentit açò en la vida, però
vaig optar per el que aconsellaven, de traduir la password que jo havia
especificat al Escriptori Remot de ubuntu, amb aquest "traductor" a base64.
http://makcoder.sourceforge.net/demo/base64.php

Tampoc rula :(

Totes les meves proves les he fet dins la xarxa local (per descartar coses),
amb una password molt sencilla de menys de 8 caràcters, amb el escriptori
remot amb la casella de Demanar confirmació (local) desactivada, i amb les
caselles de permetre que controlen el pc i el vejen via VNC activades.

Els clients que he emprat, tots els posibles, tighVNC, UltraVNC, RealVNC, i
el propi de ubuntu amb una conexio Linux<->Linux.

El més curiós de tot es que si desactive la password, funciona perfectament.
Pero aixi obert els ports i sense password no m'agrada gens.

Que passa a la punyetera password aquesta? em fan ja mal els ulls de tant
googlejar i visitar foros. NO TROBE RES!

2007/9/28, Moises Belda <moises a cinenautas.com>:
>
> He emprat nmap com m'heu sugerit. He fet dos proves:
> 1.- Desde un equip remot, he fet nmap IP_DEL_SERVIDOR_VNC, i m'ha surtit
> el port 5900 amb el VNC rulant com a servei.
> 2.- He entrat al equip remot per SSH, i desde alli he fet un nmap
> localhost, i em surt el mateix port 5900, obert, i amb VNC com a servei.
>
> No se si la segona prova es inutil o no, però per si de cas l'he feta.
>
>
> Al nmap que m'heu sugerit, ara mateix que estic al treball i l'he fet al
> equip de casa (que es al que pretenc conectar)  em surt que el port 5900
> obert, i el SERVICE = VNC.
>
> Jo crec que problemes de ports no es, ja q
>
> 2007/9/28, Moises Belda <moises a cinenautas.com>:
> >
> > Dades (perdoneu la falta de info):
> >
> > - Ubuntu feisty 64 bits, active servidor vnc que te ubuntu per defecte,
> > es a dir, a Preferencias->Escritorio Remoto. Li lleve la confirmacio que
> > pregunta al costat del servidor, i li fique una pass que em demanara el
> > servidor VNC.
> > - Ubuntu feisty 64 bits  al costat del client remotament (per internet),
> > amb vncviewer, "VNC authentication failed" al ficar la password
> > - Windows XP al costat del cliente tb he provat, amb UltraVNC, RealVNC
> > (i altre que no recorde), "VNC authentication failed", al ficar la password
> > - Les mateixes proves a  un portatil a la lan, amb els mateixos
> > programes que he detallat en els dos punts de dalt.
> > - Per canviar la password, solament en el GUI de ubuntu, fique la
> > password que vull. En Preferencias=>Escritorio Remoto
> > - Usuaris amb els que intente conectarme: vncviewer, ultravnc, realvnc
> > no em pregunta usuari, soles la password que tinc ficat al server, pero
> > falla al rebrela (o algo aixi)
> > - Ports oberts al router (5900-5905 i dirigits al pc amb l'escriptori
> > remot de ubuntu (o sea VNC), que es el 192.168.1.2). Ho he comprovat tot
> > mil vegades.
> >
> > Digam que jo crec que conecta (no dona fallo de conexio), pero al
> > preguntar la password i ficarlila es on em falla.
> >
> >
> > 2007/9/28, Orestes Mas <orestes a tsc.upc.edu>:
> > >
> > > A Divendres 28 Setembre 2007 08:50, Moises Belda va escriure:
> > > > Al seu moment, en una darrera instalació d'Ubuntu ho vaig deixar per
> > > > imposible perque no vaig trobar la causa de perque no puc accedir al
> > > meu
> > > > Ubuntu desde l'escriptori remot VNC que du de serie.
> > > >
> > > > Configure en el lloc del servidor que no demane confirmació allí,
> > > tan sols
> > > > una password, en fique una de 9 caracters, entre ells llestres en
> > > > minuscula, ,ajuscules i algun número. Tambè vaig fer proves amb
> > > passwords
> > > > més sencilles. Sempre obtinc el mateix, "VNC authentication failed"
> > > desde
> > > > el lloc client. Ho he fet remotament fora de la meva LAN i dins
> > > d'ella (per
> > > > si era un problema de ports).
> > > >
> > > > Es una Ubuntu Feisty de 64 bits, i es una nova instalacio (no
> > > aquella que
> > > > em fallava, la qual cosa indica que sempre em passarà per defecte
> > > acabat de
> > > > instalar el sistema).
> > > >
> > > > Algu sap que pot passar?
> > >
> > > Més que res per anar descartant coses, dóna'ns una mica més
> > > d'informació al
> > > voltant de la infrastructura que utilitzes: Els 2 ordinadors a
> > > connectar són
> > > dins de la mateixa LAN, o bé hi ha algun router pel mig? Quina ordre
> > > fas
> > > servir per canviar els passwords en el servidor? Amb quin usuari
> > > intentes
> > > connectar-te?
> > >
> > > Potser estic donant pals de cec, però és per descartar coses. Si tot
> > > això és
> > > correcte jo aniria a cercar coses més obscures i m'inclinaria per
> > > problemes
> > > de PAM (/etc/security/access.conf, per exemple), però m'estranya que
> > > no
> > > estigui ben configurat de sèrie...
> > >
> > > --
> > > Orestes Mas Casals - UPC
> > > GNU/Linux User 285092 / Clau pública GnuPG: 0x97451E6A
> > > Membre de l'equip català de KDE: http://cat.kde.org/
> > > Ubuntaire en Català: http://ubuntu.cat/
> > > _______________________________________________
> > > Ubuntucat-info mailing list
> > > Ubuntucat-info a cpl.upc.edu
> > > https://lists.lafarga.cpl.upc.edu/mailman/listinfo/ubuntucat-info
> > >
> >
> >
> >
>
>
-------------- part següent --------------
Un document HTML ha estat eliminat...
URL: <http://llistes.cpl.upc.edu/pipermail/ubuntucat-info/attachments/20071010/5c09ad14/attachment.html>


Més informació sobre la llista de correu Ubuntucat-info